Forum Coding Corner avrdude error when trying to connect to ATmega328P

  • This topic has 8 replies, 3 voices, and was last updated 2 years ago by kkttbogart.
Viewing 5 reply threads
  • Author
    • #6729


        I tried to connect my motherboard with a USB FTDI module by connecting the DTR, RX, TX, VCC, and GND. I tried one of the basic codes. Whenever I tried to upload, I get the following:

        avrdude: stk500_recv(): programmer is not responding
        avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
        avrdude: stk500_recv(): programmer is not responding
        avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00

        Looking it up, I found on Arduino website that this error occurs when the native port is not correctly selected:

        This error can occur when the selected port has no board. For example, the Bluetooth port might be selected instead of the USB port where the Arduino board is connected.

        On Arduino IDE, I don’t have any other port to select except for one. I think I need some help on this one.

        Thank you in advance.

      • #6802

          Hi! I’m really sorry, your post was pending due to having links and code. I didn’t realise I had to approve these posts. I do now!

          Are you still having trouble? Does the port show up when the FTDI module is connected then disappears when disconnected? Are the connections to the Motherboard correct? Are you using a Short Circuits FTDI module or one from China (these could have different connections)? Is your ATMega328P connected the right way round? The notch in the chip should be on the right. Are there any solder bridges between pins on the ATMega328P or the FTDI connector?

          A photo of your setup may help shed some light.

          Sorry for the delay in approving the post. I hope we can find a solution to your problem.

        • #6866

            I am now having the same problem. I managed to upload the first Blinks SOS sketch, without any problems. It now runs this sketch each time the motherboard is powered via USB instead of the simple Blink that the chip originally came with. I know therefore that all of the connections and soldering are correct. I cannot upload any other sketch however as it gives the same error as @alaa-badredine above has reported, i.e.:

            …………… avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x05
            avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x05
            Problem uploading to board. See for suggestions.

            I have been through all of the checks given in at the website but still cannot find anything wrong with my set-up.
            Any suggestions?
            It’s stopping me from going on any further with all the other boards.


            • #6867

                Hi Michael,

                Could you send me a photo of your board when it’s connected?
                Do you have a Bluetooth module connected?
                When clicking on tools in the Arduino IDE, is Board set to “Arduino Uno” and the Port is correct (COM13 for example)?
                Does this port disconnect as expected when you pull the USB?
                Have you tried the FTDI module on another Arduino? Do you have another FTDI to try?
                Try a different USB port? Different computer?

                This stuff can take a lot of trial and error. It’s part of learning how to troubleshoot this sort of thing, and I have probably sunk a few hundred hours into it. Without the hardware in front of me, it is a little tricky to diagnose.

                I hope some of that helps. Let me know how you get on. I should receive an email if you respond, so I won’t miss your post (sorry about the delayed response).


            • #7102

                Trying to use to run a simple sketch and its not working getting the ser_open()

                I am trying an Arduino_Uno.

                I have tried every idea posted in this forum also.


                • #7103

                    OK, so the 8 segment displays came on, but the led’s did not. I can very that the file is not getting loaded to the arduino.

                    I jumpered the led’s on the board and verified that my solder joints were good. So there fore I just need a good ftdi interface and I will be good.

                    Hope this helps

                • #7113

                    Yeah, no. I spent 4 hours doing this last night. I dont use Cura. I am assuming you mean the slicing software?

                  • #7133

                      All. The best way to fix this error is to take out the chip and then program it using an Arduino board where you can replace it with the one there.

                      I was able to get the code to work and see the switches and displays work.

                      I used a Uno clone from Sainsmart to accomplish this.

                  Viewing 5 reply threads
                  • You must be logged in to reply to this topic.